Project

General

Profile

Bug #176

don't crash on unexpected exceptions during CSV import

Added by Tony Ciavarella over 7 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
Normal
Target version:
Start date:
12/11/2011
Due date:
% Done:

100%

Estimated time:

Description

On Sun, Dec 11, 2011 at 8:00 AM, Duncan C. <...> wrote:

Hi,

Great app - it was the first one I ever paid money for.

Minor Bug Report
Note: I know what I was doing below isn't expected to work...

Steps to reproduce:
1. Exporte data to a csv file
2. Manually remove the sleep quality values - leaving ,, instead of ,[0-9],
3. Import altered csv file

Result:
As expected, Sleepmeter doesn't like this, but instead of giving me an error the program crashed.

Why I came across this:
For a while I've been using the sleep quality slider to record something that isn't sleep quality, but recently no longer need to record that any more. So since the old records weren't useful any more I tried to get rid of the values so that I could actually use it for what it was meant for going forward, without having the previous records affect the computed statistics.

Feature request?
The ability to record arbitrary zero to n rated statistics along with each sleep record (e.g. level of productivity yesterday, times woken up [for people who don't want to fill out all the details associated with holes], temperature of room, level of stress, quality of mood, number of kittens hoarded while sleepwalking). But meh... this is only really a nice-to-have for me, not a deal breaker...

- Duncan

History

#1 Updated by Tony Ciavarella over 7 years ago

  • Status changed from New to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF