Project

General

Profile

Bug #248

GUI command processing is still crashing sometimes

Added by Tony Ciavarella over 6 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
High
Target version:
Start date:
02/12/2013
Due date:
% Done:

100%

Estimated time:

Description

These are from google play:

Level 11 UI:

java.lang.IllegalStateException: Can not perform this action after onSaveInstanceState
at android.app.FragmentManagerImpl.checkStateLoss(FragmentManager.java:1265)
at android.app.FragmentManagerImpl.enqueueAction(FragmentManager.java:1276)
at android.app.BackStackRecord.commitInternal(BackStackRecord.java:541)
at android.app.BackStackRecord.commit(BackStackRecord.java:525)
at com.android.internal.app.ActionBarImpl.selectTab(ActionBarImpl.java:517)
at com.android.internal.app.ActionBarImpl.setSelectedNavigationItem(ActionBarImpl.java:306)
at com.squalllinesoftware.android.applications.sleepmeter.eq.run(Level11GUI.java:206)
at android.os.Handler.handleCallback(Handler.java:605)
at android.os.Handler.dispatchMessage(Handler.java:92)
at android.os.Looper.loop(Looper.java:137)
at android.app.ActivityThread.main(ActivityThread.java:4697)
at java.lang.reflect.Method.invokeNative(Native Method)
at java.lang.reflect.Method.invoke(Method.java:511)
at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:787)
at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:554)
at dalvik.system.NativeStart.main(Native Method)

Level 4 UI:

java.lang.RuntimeException: Error receiving broadcast Intent { act=com.squalllinesoftware.android.applications.sleepmeter.paid.gui_command pkg=com.squalllinesoftware.android.applications.sleepmeter.paid (has extras) } in com.squalllinesoftware.android.applications.sleepmeter.GUI$CommandManager@40564bd8
at android.app.LoadedApk$ReceiverDispatcher$Args.run(LoadedApk.java:765)
at android.os.Handler.handleCallback(Handler.java:587)
at android.os.Handler.dispatchMessage(Handler.java:92)
at android.os.Looper.loop(Looper.java:150)
at android.app.ActivityThread.main(ActivityThread.java:4385)
at java.lang.reflect.Method.invokeNative(Native Method)
at java.lang.reflect.Method.invoke(Method.java:507)
at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:849)
at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:607)
at dalvik.system.NativeStart.main(Native Method)
Caused by: java.lang.IllegalStateException: Can not perform this action after onSaveInstanceState
at android.support.v4.app.l.s(FragmentManager.java:1299)
at android.support.v4.app.l.a(FragmentManager.java:1310)
at android.support.v4.app.b.a(BackStackRecord.java:541)
at android.support.v4.app.b.a(BackStackRecord.java:525)
at com.squalllinesoftware.android.applications.sleepmeter.en.onTabChanged(Level04GUI.java:279)
at android.widget.TabHost.invokeOnTabChangeListener(TabHost.java:359)
at android.widget.TabHost.setCurrentTab(TabHost.java:344)
at com.squalllinesoftware.android.applications.sleepmeter.Level04GUI.a(Level04GUI.java:182)
at com.squalllinesoftware.android.applications.sleepmeter.GUI$CommandManager.a(GUI.java:119)
at com.squalllinesoftware.android.applications.sleepmeter.GUI$CommandManager.onReceive(GUI.java:93)
at android.app.LoadedApk$ReceiverDispatcher$Args.run(LoadedApk.java:748)
... 9 more

History

#1 Updated by Tony Ciavarella over 6 years ago

  • Status changed from New to Closed
  • % Done changed from 0 to 100

I'm closing this with hopes that r1170 fixed it. If not, re-open.

Also available in: Atom PDF