Project

General

Profile

Bug #72

quick rotation seems to crash edit mode record tab

Added by Tony Ciavarella over 8 years ago. Updated over 8 years ago.

Status:
Closed
Priority:
High
Target version:
Start date:
01/11/2011
Due date:
% Done:

100%

Estimated time:

Description

Quickly rotating the record tab in edit mode seems to repeatably produce a NPE. It never seems to happen in add mode, only edit mode triggers the problem.

The NPE leaves the following stack trace:

Uncaught handler: thread main exiting due to uncaught exception
java.lang.RuntimeException: Unable to pause activity {com.squalllinesoftware.android.applications.sleepmeter.paid/com.squalllinesoftware.android.applications.sleepmeter.DataEntryActivity}: java.lang.NullPointerException
at android.app.ActivityThread.performPauseActivity(ActivityThread.java:3059)
at android.app.ActivityThread.performPauseActivity(ActivityThread.java:3016)
at android.app.ActivityThread.handleRelaunchActivity(ActivityThread.java:3473)
at android.app.ActivityThread.access$2200(ActivityThread.java:116)
at android.app.ActivityThread$H.handleMessage(ActivityThread.java:1798)
at android.os.Handler.dispatchMessage(Handler.java:99)
at android.os.Looper.loop(Looper.java:123)
at android.app.ActivityThread.main(ActivityThread.java:4203)
at java.lang.reflect.Method.invokeNative(Native Method)
at java.lang.reflect.Method.invoke(Method.java:521)
at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:791)
at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:549)
at dalvik.system.NativeStart.main(Native Method)
Caused by: java.lang.NullPointerException
at com.squalllinesoftware.android.applications.sleepmeter.DataEntryActivity.onSaveInstanceState(DataEntryActivity.java:727)
at android.app.Activity.performSaveInstanceState(Activity.java:1020)
at android.app.Instrumentation.callActivityOnSaveInstanceState(Instrumentation.java:1256)
at android.app.ActivityThread.performPauseActivity(ActivityThread.java:3041)
... 12 more

History

#1

Updated by Tony Ciavarella over 8 years ago

  • Subject changed from quick rotation seems to crash record tab to quick rotation seems to crash edit mode record tab
#2

Updated by Tony Ciavarella over 8 years ago

  • Status changed from New to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF